Which Browsers support Sage People?

Sage People WX supports the following browsers:

  • Apple Safari version 5 or later
  • Google Chrome
  • Microsoft Internet Explorer version 10 or later;
    • Salesforce applies some limitations to support for Internet Explorer. Refer to Salesforce help topics for Supported Browsers for more information.
  • Mozilla Firefox version 4 or later
  • Opera version 11 or later

** For Internet Explorer and Edge you may need to add *.visual.force.com and *.salesforce.com to the trusted site list in Internet Explorer to get the pages to load properly.

Sage People WX supports the following browsers:

  • Apple Safari version 5 or later
  • Google Chrome
  • Microsoft Internet Explorer version 10 or later;
    • Salesforce applies some limitations to support for Internet Explorer. Refer to Salesforce help topics for Supported Browsers for more information.
  • Mozilla Firefox version 4 or later
  • Opera version 11 or later

** For Internet Explorer and Edge you may need to add *.visual.force.com and *.salesforce.com to the trusted site list in Internet Explorer to get the pages to load properly.

Frequently searched for

Help Videos

View Support Videos

Videos
Site Help

Need help navigating this site?

Site Help

Need support fast

After reviewing the guides and videos if you need further help please contact us.

Raise a case